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Avant-propos 
 
Ce document a pour but d’aider à la prise du logiciel Altium Designer v19 pour la saisie de 
schématique, le placement-routage d’un circuit imprimé et la génération des fichiers de fabrication. Ce 
document de prise en main n’a pas vocation à être exhaustif. Plus d’informations sur l’utilisation de ce 
logiciel peuvent être trouvées sur le site officiel www.altium.com.  
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I. Présentation d’Altium Designer 
Altium Designer est un environnement complet de développement de produits électroniques incluant, 
entre autres :  

 un outil de conception de circuits imprimés (Printed Circuit Board ou PCB) 
 un outil de simulation SPICE 
 un outil de développement FPGA  
 un outil de développement de code embarqué 

 
Altium Designer ne fonctionneque sous les environnements Windows. Pour en savoir plus sur le 
logiciel, reportez vous au site d’Altium : http://www.altium.com/products/altiumdesigner/ . Ce 
document est focalisé uniquement sur la conception de circuits imprimés. 
 
 

Le démarrage de l’outil se fait en cliquant sur l’icône Altium Designer , disponible aussi dans 
le menu Démarrer. L’écran de démarrage au premier lancement du logiciel est présenté à la Figure 
1.La barre de menu en haut permettra de créer de nouveaux projets. Le volet Projects à gauche 
permettra de naviguer dans les différents projets que vous créerez. L’affichage des différents volets, 
barres de commandes et de statut peut être configuré à l’aide du menu View dans la barre de menu. 
 

 
Figure 1 – Ecran de démarrage du logiciel Altium Designer 

 
 
 

II. Flot de conception d’une carte électronique 
La Figure 2 décrit le flot typique et simplifié de la conception d’un circuit imprimé (PCB). Un projet 
PCB contient au moins deux documents : 
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 une schématique, décrivant le schéma électrique de l’application. Les composants électriques 
sont représentés par des symboles et reliés par des interconnexions électriques 

 un document PCB, décrivant le placement physique des composants sur la carte et le routage 
des interconnexions 

 

Saisie de la 
schématique

Lien symboles -
empreintes

Vérification électrique 
(ERC)

Création d’un projet PCB

Spécification carte et 
règles de routage

Transfert du schéma sur 
le document PCB

Placement composants/ 
Routage PCB

Vérification routage 
(DRC)

Fichier de sortie

Document de 
schématique

Document de 
routage

 
Figure 2 – Flot de conception d’un circuit imprimé (PCB) 

 
Ces deux documents sont liés. A chaque composant électronique, on associe un symbole électrique 
et une empreinte physique qui apparaitra sur le circuit imprimé. La première phase consiste à définir 
le schéma électrique. On sélectionne dans une librairie les différents symboles électriques des 
composants, on leur attribue des empreintes et on les relie. Après une validation électrique, le 
document de routage PCB, dont les propriétés ont été au préalable spécifiées (nombre de couches, 
dimensions, contraintes…), est mis à jour en fonction de la schématique. Les empreintes des 
composants sont déposées aléatoirement sur la surface de routage, les interconnexions entre les 
circuits apparaissent sous forme de liens virtuels. Les 2 étapes qui suivent sont : 

 Le placement des composants sur la carte 
 Le routage des interconnexions, qui vont être matérialisées par des lignes métalliques 

 
A la fin de ces deux phases, une vérification de la correspondance entre le routage et la schématique 
et du respect des règles de routage (Design Rule Check DRC) est appliquée fin de valider le design. 
Une fois le design validé, des fichiers de sortie peuvent être extraits pour réaliser les différents 
masques servant à fabriquer la carte, vérifier l’intégration mécanique de la future carte, établir la liste 
d’achat des composants, préparer l’implémentation des composants sur la carte ... Les parties qui 
vont suivre décrivent comment réaliser ces différentes étapes sous Altium Designer.  
 
 

III. Créer un projet PCB 
Sous Altium Designer, un projet est composé d’un ensemble de documents reliés au design. Les 
projets PCB ont l’extension name.PrjPCB. Il s’agit d’un fichier ASCII listant tous les documents et les 
réglages de sortie (pour l’impression et CAM).  
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Pour créer un nouveau projet, cliquez sur File>New>project depuis la fenêtre de démarrage d’Altium 
(Figure 1). Pour le type de projet, sélectionnez <Default>. Renommer le nouveau et indiquer le 
chemin d’accès sur le disque. Pour l‘instant, le projet est vide, aucun document n’a été ajouté. La 
prochaine étape consiste à créer la schématique et de l’ajouter dans le projet. Pour de futures 
utilisations, des fichiers de schématique et de routage existants pourront être ajoutés dans le projet. 
 

IV. Saisie d’une schématique 

1. Création d’une schématique 
On créé une nouvelle schématique en cliquant sur File>New>Schematic. Une feuille de saisie de 
schématique vierge apparaît (Figure 3), nommée Sheet1.SchDoc, qui est automatiquement ajouté au 
projet dans la liste Source documents. On renomme la fiche avec File>Save As. Il est possible 
d’ajouter une schématique existante au projet à l’aide d’un clique droit au dessus du nom du projet 
dans le panneau Projects et en sélectionnant Add Existing to Project.  La saisie de la schématique 
se fait dansla zone centrale de l’écran. Une barre d’outils donne accès aux principaux outils de saisie 
de la schématique. Ceux-ci sont aussi disponibles dans le menu Place ou à l’aide de raccourci clavier. 
Plusieurs panneaux, disponibles à droite de l’écran, peuvent être ouverts, comme Components pour 
l’ajout de composants sur la schématique, et Properties pour modifier les propriétés de la 
schématique (grille de saisie, unités, couleur, filtres…). L’affichage de ces panneaux est configurable 
à l’aide du bouton Panels en bas à droite.  

Zone de saisie de la schématique

Informations sur 
la schématique

Navigateur 
projets

Barre d’outils de saisie 
de schématique

Accès aux composants

Accès aux propriétés du 
document ou composant 

sélectionné

 
Figure 3 – Création d’une nouvelle schématique 

 
Avant de démarrer la saisie de la schématique, il est nécessaire de paramétrer les options de la fiche. 
Aller dans Design>Template>General template. Sélectionner le format de la fiche (exemple : A4).  
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Figure 4 – Modification des options du document de schématique 

 
Ensuite, il faut configurer les préférences générales de la schématique : Tools>Preferences. 
Sélectionner par exemple dans la liste de gauche Schematic – Defaults et cocher la case 
Permanent. Dans Schematic – General sélectionner le système métrique (mm) ou impérial (mils) 
pour les unités.  Terminez en cliquant sur OK. 

2. Saisie de la schématique 
Maintenant, il est possible de saisir une nouvelle schématique. Dans 
un premier temps, il est nécessaire de localiser les composants dans 
les différentes librairies fournies par l’outil, puis de charger ces 
librairies. Cliquez sur View>Panels>Components ou directement sur 
le panneau Components à droite de l’écran pour afficher le panneau 
d’exploration des librairies. Le bouton librairie est alors disponible sur 
le bord droit de la fenêtre. La fenêtre présentée sur la Figure 5 
apparait en cliquant sur ce bouton. Pour trouver un composant, il faut 
tout d’abord sélectionner une librairie. Par défaut, les librairies 
Miscellaneous Devices et Miscellaneous Connectors sont chargées. 
Ensuite pour trouver un composant, il est possible d’utiliser la fonction 
Search ou de le chercher dans la liste. 
 
Différentes informations sont reliées à chaque composant : un 
symbole, une empreinte, un modèle pour la simulation électrique, 
pour la simulation d’intégrité de signal. 
Pour placer un composant sur la schématique, sélectionnez ce 
composant dans sa librairie, puis glissez-le sur la schématique. Vous 
pouvez ensuite déplacer le composant qui reste flottant et le placer à 
l’endroit voulu par un simple clic ou en appuyant sur Entrée.  
  

Figure 5– Panneau Libraries 
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Lorsqu’il est flottant, on peut le faire tourner à l’aide de la barre d’espace (Shift + barre d’espace 
permet de le faire tourner dans le sens inverse), éditer ses propriétés à l’aide de la touche Tab, 
changer son orientation à l’aide de la touche x ou y (opération miroir selon l’axe X ou Y). L’ensemble 
des commandes de placement et manipulation des composants sur la schématique est disponible 
dans le menu Edit. Les opérations de copier-couper-coller sont possibles grâce aux raccourcis 
claviers usuels (CTRL+C,+V,+X). 
 
Une fois le composant placé, il est possible d’afficher ses caractéristiques par un double clic, on fait 
apparaître ses propriétés. Dans cette fenêtre, on peut éditer et modifier le nom, les valeurs, le boîtier, 
le brochage et d’autres propriétés. Pour chaque composant, il est important de compléter Designator, 
Comment et Description. Designator sert à identifier le composant dans le projet, il doit être court et 
explicite, par exemple RH2 pour la résistance 2 du bloc en haut du circuit. Comment décrit le 
composant, il faut rentrer son nom ou sa caractéristique principale, LMH6703 pour un AOP par 
exemple. Description permet d’expliciter toutes les caractéristiques du composant. Une propriété 
indispensable pour l’opération de routage est le ou les boîtiers associés à un composant. Celle-ci est 
accessible dans la partie Footprint. En cliquant sur le bouton Add, on accède aux librairies 
d’empreintes existantes et on peut sélectionner l’empreinte à associer au composant. 
Pour supprimer un composant on le sélectionne et on clique sur la touche Suppr. 

 
Figure 6  – Fenêtre properties 

 
Une fois les composants placés, on peut les connecter. Pour cela, cliquez sur Place>Wire ou sur le 

bouton . Cliquer ou appuyer sur entrée pour connecter la première extrémité du fil, faire de même 
pour connecter la seconde extrémité. Une fois les composants interconnectés, on peut les déplacer 
sans casser les connexions en cliquant sur Edit>Move>Drag. Vous pouvez le faire en bougeant 
normalement le composant tout en appuyant sur la touche Control.  

 
Figure 7  – Création d’un lien entre deux composants 
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Avec un clic droit sur  on accède aux nœuds globaux (GND et Power Port). Ils permettent de 
garder une schématique claire car ils évitent d’utiliser des câbles pour connecter les nœuds communs. 
On les utilise en général pour les alimentations et la masse. 
 
Conseil : Utilisation des net labels 
Pour clarifier la schématique, il est conseiller de nommer les nœuds, avec des noms explicites (par 
défaut, le logiciel nomme les nœuds avec des références plutôt longues et peu mémorisables). Pour 
placer des labels de nœuds, cliquez Place>Net Label et placer le sur le fil à nommer. Une croix 
rouge apparaît quand le logiciel détecte un nœud à nommer. Vous pouvez entrer le nom du label en 
cliquant sur tab si le label est encore flottant ou en double cliquant dessus. Ces net labels permettent 
aussi de créer une connexion logique entre les broches de différents composants, équivalente à la 
connexion physique basée sur un fil. Leur utilisation permet donc de réduire le nombre de fils tirés sur 
une schématique et de la clarifier. Cela s’avère particulièrement important pour une schématique 
complexe, présentant un grand nombre de composants et de connexions. 
 
Pour plus d’informations sur la connectivité entre les composants d’une schématique, vous pouvez 
consulter le document suivant : https://www.altium.com/documentation/altium-designer/creating-
connectivity-ad?version=18.1  
 

3. Schématique multisheets 
Jusque-là, nous avons vu comment créer une schématique sur une feuille ou sheet unique. Cette 
approche est satisfaisante pour un circuit simple ou pour un bloc fonctionnel. Cependant, lorsque le 
circuit imprimé à réaliser contient de nombreux composants et de connexions, placer l’ensemble des 
composants sur une même feuille devient difficile hormis si on l’élargit. Cependant, la lisibilité du 
document en souffrira ! 
Une meilleure alternative consiste à répartir l’ensemble des composants du circuits sur différentes 
feuilles : on parle alors de schématique multsheets. En plus du gain de lisibilité, cette manière de 
saisir les schématiques permet d’adopter une méthode de conception plus modulaire, c’est-à-dire 
qu’une partie d’un circuit peut être facilement réutilisée dans un autre projet. Pour correctement 
utiliser cette approche, il convient au préalable de décomposer le circuit en modules, où chaque 
module présente une cohérence fonctionnelle Par exemple, sur une carte digitale avec un 
microcontrôleur, on peut certainement décomposer le circuit en un module alimentation (contenant 
l’ensemble des connecteurs d’alimentation, des régulateurs, des filtres d’alimentation …), un module 
microcontrôleur (contenant le symbole du microcontrôleur avec l’ensemble de ces broches), un 
module connecteurs (contenant les connecteurs de communication, d’entrée-sortie …), … 
 
On créé une schématique multisheets dès lors que deux fichiers schématiques sont présents dans le 
même projet (et que l’on a décidé de répartir les composants sur ces deux schématiques) Sur Altium, 
il existe deux manières de réaliser des schématiques multisheets, dépendantes de la manière dont 
les feuilles sont organisées entre elles : 

 Design à plat ou flat design : il n’existe aucune hiérarchie entre les différentes feuilles ; on dit 
qu’elles sont au même niveau hiérarchique 

 Design hiérarchique : il existe une hiérarchie de type parent-enfant entre les différentes 
feuilles.  

 
Dans les paragraphes ci-dessous, les principaux concepts pour créer une schématique multisheets 
sont donnés. Pour des informations plus détaillées, vous pouvez le document suivant : 
https://www.altium.com/documentation/altium-designer/multi-sheet-and-multi-channel-design-
ad?version=18.1   
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La difficulté pour l’outil est de déterminer 
correctement les connexions entre des nœuds 
électriques répartis sur différentes feuilles. La 
technique de connectivité utilisée par Altium peut 
être configurée à l’aide de l’option Net Identifier 
Scope, qui se trouve dans le menu Project > 
Project Options, puis dans l’onglet Options.  
 

 

Par défaut, le mode Automatic est sélectionné. Celui-ci est suffisant dans la plupart des situations. 
Néanmoins, en cas de problèmes de connectivité, il peut être nécessaire de modifier cette option. 
 

a. Flat design 
Un flat design est assez trivial à réaliser. Les composants sont 
répartis sur différentes feuilles, en cherchant à les regrouper par 
blocs fonctionnels. Ces différentes feuilles correspondent à 
différents fichiers de schématique, placés au même niveau 
hiérarchique. Dans la vue projet, les fichiers schématiques 
apparaissent au même niveau dans la partie Source 
Documents, comme le montre l’exemple ci-contre contenant 
deux schématiques appelées Sheet1.schdoc et Sheet2.schdoc. 

 

 
A l’intérieur d’une même feuille, les connexions entre les composants se font comme précédemment 
à l’aide de fil ou de net labels. Par contre, pour créer une connexion entre deux composants présents 

sur deux feuilles différentes, il est nécessaire d’utiliser des ports représentés par le symbole .  
 
Ceux-ci sont disponibles la barre de saisie de schématique ou 
dans le menu Place > Port. Lorsqu’on place un port, il est 
nécessaire de préciser son nom (qui servira d’identifiant à Altium) 
et le type d’I/O (Input, Output, Bidirectional). Pour connecter deux 
broches de composants placés sur deux feuilles différentes à 
travers deux ports, il est évident que ces deux ports doivent avoir 
le même nom. De plus, leurs types d’I/O doivent être cohérents 
(deux I/O de type Input ne peuvent être connectés en semble, 
contrairement à une I/O de type Input avec une /O de type Output). 
 
Remarque : Lorsque deux broches sur deux feuilles différentes 
sont connectées par un port, il ne faut pas attribuer un net label à 
cette connexion. On essaierait de créer une deuxième connexion 
logique entre ces broches, alors qu’il ne peut y avoir qu’une seule 
connexion logique ! 

 
 
 
L’exemple (très simple) ci-dessous, présente un exemple de flat design. Celui-ci est composé d’un 
connecteur à deux broches (contenu dans la schématique appelée Sheet1.schdoc) et de deux 
résistances en parallèles (contenus dans la schématique appelée Sheet2.schdoc). La connexion 
entre les résistances et une des broches du connecteur se fait par l’intermédiaire d’un port appelé 
Port1 (ici, de type bidirectionnel). Si Altium parvient à réaliser la connectivité entre ces deux 
schématiques, la compilation est réussie : le connecteur et les deux résistances sont connectées. 
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Figure 8  – Exemple de flat design : à gauche le connecteur contenu dans le fichier Sheet1.schdoc, à 

droite les résistances contenus dans le fichier Sheet2.schdoc 
 
 

b. Design hiérarchique 
Dans un design hiérarchique, il y a au moins une feuille parente qui fait appel à une ou plusieurs 
feuilles enfants. L’exemple précédent est repris pour illustrer un design hiérarchique.  
 
Le circuit est toujours formé d’un connecteur (contenu dans 
le fichier Sheet1.schdoc), deux résistances (contenu dans le 
fichier Sheet2.schdoc) et d’un condensateur (contenu dans le 
fichier Sheet3.schdoc). Ces trois feuilles contiennent trois 
parties distinctes d’un même projet, dont la feuille parente 
(appelée Top sheet) est contenu dans le fichier 
Top_sheet.schdoc. Ci-contre, la vue projet est présentée et 
montre bien la relation de dépendance entre le fichier 
Top_sheet.schdoc et les trois autres fichiers schématiques. 

 

 
Ces différentes feuilles peuvent être créées comme nous l’avons précédemment. Les fichiers 
schématiques peuvent préexister et il suffit de les importer dans le projet à l’aide de la commande 
Project > Add Existing to Project. Comme pour un flat design, les connexions entre les différentes 
feuilles se feront par l’intermédiaire des ports. Supposons que les trois feuilles enfants existent et que 
leurs schématiques déjà saisis. Il ne reste plus qu’à créer la feuille parente. Il existe plusieurs 
manières de faire apparaitre les feuilles enfants : 

 

 On place un symbole Sheet , qui se trouve dans la barre 
de saisie de schématique ou dans le menu Place > Sheet 
symbol. Dans les propriétés (ci-contre), on indique le fichier 
schématique associé (File Name), le désignateur ainsi que 
l’ensemble des ports d’entrée-sortie (Sheet Entries). 
 

 A l’aide de la commande Design > Create Sheet Symbol 
from Sheet, on sélectionne une des feuilles existantes. 
Automatiquement, Altium créé le symbole Sheet avec ces 
ports d’entrée-sortie. 
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La figure ci-dessous présente la vue schématique de la feuille Top_sheet.schdoc. Pour ouvrir une des 
schématiques enfants, il suffit de la sélectionner, un clic droit et sélectionner Sheet Symbol 
Actions > Open Subsheet xxx.schdoc dans le menu déroulant. 

 
Figure 9  – Exemple de design hiérarchique – schématique de la feuille parente. Elle est formée de trois 

symboles Sheet, contenant trois parties du circuit 
 

 

4. Compilation de la schématique 
Altium propose différents moyens de vérification de la schématique construite (electrical rules, matrice 
de connectivité, comparateur, …). Tout cela se paramètre à partir de Project>Project Options. La 
fenêtre de dialogue ci-dessous s’ouvre, permettant de configurer le rapport d’erreur pour toutes les 
fautes possibles. 

 
Figure 10 – Configuration de la vérification de la schématique 

 
La fenêtre Error Reporting permet de configurer le niveau de sévérité d’une violation de connectivité 
donnée. La fenêtre Connection Matrix permet de vérifier les connections électriques entre broches, 
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ports ou fiches et de configurer le niveau de sévérité des violations associées. Les carrés de couleur 
indiquent les niveaux de sévérité, qui peuvent être modifiés en cliquant dessus. 
On commence par compiler le projet et vérifier si il y a ou non des erreurs en cliquant sur  
Project>Compile PCB Project. Les éventuels messages d’erreur ou d’avertissement s’affichent dans 
le volet Messages (qu’on fait apparaître sous la fenêtre de schématique en cliquant sur 
View>Panels>System>Messages). S’il n’y a pas eu d’erreurs ou de warnings, le volet Messages 
reste vide.  
Une fois la schématique validée, il est possible de transférer la schématique électrique sur le PCB. 
 
En cliquant sur Reports>Bill of Materials, une fenêtre de dialogue permet de paramétrer le fichier de 
sortie contenant la liste des composants (bill of materials BOM), essentielle lors de l’achat des 
composants et la préparation de l’assemblage du circuit imprimé (cf VI.3). On remarque alors qu’il est 
important de remplir pour chaque composants les champs Designator, comment et description de 
chaque composant. 
 

V. Routage PCB 
Le routage PCB se fait toujours en étroite relation avec la schématique. La schématique permet de 
définir les connexions électriques entre les différents composants. Pour pouvoir faire le lien entre la 
schématique et le PCB, les composants des librairies sont non seulement définis par un symbole de 
schématique mais aussi par une empreinte de PCB. Une fois la saisie de la schématique terminée et 
validée, on peut mettre à jour le PCB. Les composants avec leurs empreintes physiques apparaissent 
à la surface du PCB, une connexion virtuelle entre 2 composants connectés apparaît entre leurs pads. 
Le routage consiste d’abord à placer les composants puis à router les interconnexions physiques 
entre les composants. Toute modification du routage qui brise la correspondance avec la 
schématique conduit inévitablement à une erreur, qui sera détecté par le logiciel de routage. 

1. Création d’un nouveau document PCB 
 
Avant de transférer le design depuis l’éditeur de 
schématique vers l’éditeur PCB, il faut créer un PCB 
vierge, dont on définit la taille, le nombre de couches, 
les épaisseurs, et les règles de routage. Pour cela, 
cliquer sur File>New>PCB, lui attribuer un nom 
File>Save as. Il est ensuite nécessaire de positionner 
l’origine du repère orthonormé sur la carte 
Edit>Origin>Set. L’origine du repère est indiqué par 
un symbole caractéristique, illustré sur la Figure 11. 
Pour la modifier, placez le curseur dans le coin 
inférieur gauche par exemple. Pour ajouter une grille 
sur le PCB appuyer sur View>Grids>Set Global Snap 
Grid. 

 
Figure 11 – Origine du PCB 

 
Ensuite, nous voulons choisir la taille et la forme de notre carte. Pour cela il faut passer en mode 
édition View>Board planing mode. A chaque fois que l’on voudra apporter des modifications à la 
structure du PCB, il faudra retourner dans ce mode. On peut maintenant modifier le PCB. Si on veut 
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uniquement changer les dimensions du rectangle on clique sur Design>Edit board shape. Si on 
veut aussi modifier la forme on clique sur Design>Redefine board shape. 

 
Figure 12 – Exemple de redéfinition de la forme d’un circuit imprimé rectangulaire 

 
 
Lorsque toutes ces étapes sont terminées, on peut retourner dans le mode 2D View>2D layout 
mode. La fenêtre ci-dessous s’affiche, l’éditeur de PCB vient de s’ouvrir. C’est depuis cet éditeur que 
nous allons pouvoir router la carte. Son aspect est identique à celui de l’éditeur de schématique. Seul 
la barre de menu et son contenu a évolué. 
 

Navigateur 
projets

Barre d’outils de saisie 
du routage

Surface du circuit imprimé (les 
composants sont routés ici !)

Sélection de la couche de routage courante

Origine

 
Figure 13 – Vue d’ensemble de l’éditeur de schématique 

 
Le PCB apparaît en noir sur une feuille grise. Sur la base inférieure de l’éditeur apparaissent les 
couches physiques, mécaniques et de masque qui nous permettront de router la carte. A gauche, 
cliquer sur l’onglet Properties à partir de cette fenêtre, on peut aussi configurer la grille électrique 
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(Electrical Grid). Celui-ci nous aidera durant le placement des composants puisque ceux-ci se 
fixeront automatiquement sur cette grille (Snap Grid).  En général, on configure le champ Visible 
Grid avec la valeur de l’espacement entre 2 broches d’un boîtier. 2.54 mm est une valeur standard. 
Pour l’ensemble des dimensions des grilles, il est préférable d’employer des sous multiples et des 
multiples d’une même valeur. Si la taille de la grille est de 2.54 mm, il convient de fixer la taille de 
Snap Grid à 0.254 mm ou 0.127 mm. 
 
Remarque : pour changer l'unité (passer de mm à mils ou inversement), cliquez sur View/Toggle 
Units ou utilisez le raccourci clavier Q. Pour changer la grille on peut aussi utiliser le raccourci clavier 
G. 
 

 
Figure 14 – Paramétrage des options d’un document PCB 

 
Nous devons définir l’empilement des différentes couches du PCB. Pour cela, on clique sur Design / 
Layer Stack Manager. L’écran ci-dessous s’affiche. Si seulement deux plans de signaux ont été 
définis, la figure ci-dessous ne doit pas inclure les plans Internal Plane 1 et 2. Ils n’apparaissent que 
si on a inclus 2 plans d’alimentation internes lors de la définition du circuit imprimé (cas d’un circuit 
imprimé multicouche). 
 

 
Figure 15 – Configuration de l’empilement des différentes couches du PCB 
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Nous venons de finir le paramétrage de base de la carte. Maintenant, nous allons inclure cette carte 
au projet. On peut commencer par sauvegarder le PCB (extension .PcbDoc). Le fichier apparaît dans 
l’arborescence du projet comme un Free Documents et n’appartient pas encore au projet, même si 
vous l’avez sauvé dans le même répertoire que votre projet. Pour l’inclure dans le projet, dans 
l’arborescence projet, faites un clic droit sur le nom du projet, puis Add Existing To Project et 
choisissez votre document PCB. Celui-ci sera automatiquement intégré au projet. 

2. Transfert de la schématique sur le document PCB 
Le PCB est pour l’instant vide. Il faut maintenant transférer la schématique à votre document PCB. 
Cette opération va transférer l’ensemble des composants de la schématique à votre PCB, sur lequel 
les empreintes des composants et leurs connexions vont apparaître. Il est indispensable de vérifier 
qu’on a attribué correctement les empreintes pour chaque composant. Pour cela, allez dans la 
schématique et cliquez sur Design>Update pcb document xxx.PcbDoc. La fenêtre suivante s’ouvre.  

 
Figure 16 – Transfert de la schématique vers le document PCB 

 
L’ensemble des composants et des nœuds apparaît. Pour réaliser le transfert, cliquer sur Validate 
Changes puis Execute Changes. Si tout se passe bien, aucune erreur n’est indiquée sur cette 
fenêtre et on peut la fermer. Des modifications sur la fenêtre apparaissent comme le montre la Figure 
17. L’ensemble des empreintes des composants apparaissent dans une zone à l’extérieur de la carte. 
Les interconnexions électriques entre les composants sont symbolisées par des fils jaunes. 
L’ensemble est nommé chevelu. La prochaine opération sera le placement des composants, qui va 
consister à les placer judicieusement sur la carte. 
 
Remarque : à tout instant du placement-routage, il est possible de faire des modifications sur la 
schématique, puis mettre à jour le routage (par exemple, si on souhaite rajouter un composant, 
modifier une empreinte, revoir une connexion électrique …). On refera la manipulation précédente 
pour transférer les modifications de la schématique sur le routage. Cette opération ne modifiera pas le 
routage déjà réalisée. 
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Figure 17 – Document PCB après transfert de la schématique 

 
 

3. Placement des composants 
Pour modifier le zoom sur la carte, vous disposez de commandes dans le menu View ainsi que des 

icônes , la première sert à voir tout le document, le deuxième à faire à zoom sur une zone 
définie (les boutons Page Up et Page Down sotn des raccourcis claviers pour zoomer et dézoomer). 
Le contour physique des composants apparaît (couche Top Overlay) avec l’empreinte. L’ensemble 
des connexions entre composants non routées apparaissent aussi. Pour placer les composants, on 
les déplace à la souris sur la surface de la carte. Lors de ce déplacement, on peut les faire tourner en 
appuyant sur la touche ESPACE. En appuyant sur la touche TAB, on accède à leurs propriétés. On 
pourra ainsi modifier l’empreinte d’un composant si celle-ci ne convient pas. Si on apporte des 
modifications à la librairie de composants et que l’on veut les appliquer sur le PCB, faire 
Tool>Update from PCB libraries. On peut aussi accéder aux propriétés d’un composant en double 
cliquant dessus.  
Le placement doit se faire en commençant à imaginer à quoi doit ressembler le routage. Une fois le 
placement achevé, l’éditeur de PCB doit ressembler à quelque chose de similaire à la Figure 18. Par 
défaut, les composants se situent sur la face avant de la carte (ou Top Layer). Pour les placer sur la 
la face arrière (Bottom Layer), on clique dessus puis on cliquer sur TAB, on sélectionne Bottom Layer 
dans properties. 
 
Remarque : par convention, on observe la carte et l’ensemble de ses couches depuis le dessus. Ainsi, 
lorsqu’on route sur la face arrière, il faut qu’on l’observe depuis la face avant, comme si celle-ci et la 
carte était transparente. Il est important de s’en souvenir au moment où vous observerez la vraie 
carte car vous l’observerez depuis la face arrière. Elle apparaitra alors comme la vue symétrique de 
celle apparaissant sur le logiciel de saisie de routage !  
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Figure 18 – Placement des composants 

 

4. Routage de la carte 
Le routage de la carte consiste à relier les composants par des pistes gravées sur une couche 
physique. On dispose de deux couches ou faces pour réaliser les interconnexions entre composants 
sur une carte deux couches : 

 La face avant ou Top Layer 
 La face arrière ou Bottom Layer  

 
Conseil : lorsqu’on travaille avec des composants traversants, il est indispensable de router leurs 
pistes d’interconnexion sur la face opposée à celle où ils sont montés. Par exemple, si un composant 
traversant est monté en Top, il faudra router les pistes d’interconnexion en Bottom. Pour des 
composants montés en surface, c’est évidemment l’inverse : on place et on route sur la même face ! 
 
Avant de commencer à router, voyons les différentes couches proposées en cliquant sur 
View>Panels>View configuration (Ou taper sur la touche L). La fenêtre présentée sur la Figure 19 
apparait. On distingue les couches physiques (celles sur lesquelles on va effectivement router) des 
couches mécaniques, de sérigraphie et de masque qui vont servir à graver sur les couches physiques 
des indications utiles au concepteur ou au fabricant. On les distingue uniquement parce qu’elles n’ont 
pas le même rôle et parce qu’on ne voudra pas forcément les faire apparaitre dans le fichier de 
fabrication finale. En décochant une couche, on peut la rendre invisible. Leurs couleurs sont aussi 
modifiables individuellement. Le tableau ci-dessous liste les différentes couches disponibles, en 
précisant leurs rôles. 
 

Nom des couches Rôles 
Top/Bottom Layer Couches de routage des interconnexions sur les faces 

avant et arrière. 
MultiLayer Pour une empreinte apparaissant sur toutes les 

couches de routage (par exemple pour un via métallisé) 
Top/Bottom Overlay Couches de sérigraphie sur les faces avant et arrière 
Top/Bottom Solder Masques de soudure ou vernis-épargne (solder mask) 

sur les faces avant et arrière 
Top/Bottom Paste Couches de pâte à braser (Solder paste ou stencil) sur 
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les faces avant et arrière 
Mechanical layers Couches dédiées aux indications « mécaniques », par 

exemple pour les fichiers de perçage, d’assemblage … 
Keep-out Layer Couche servant à délimiter le bord de la carte 
DRC Couche dédiée à la visualisation des erreurs de routage 

 

 
Figure 19 – Configuration de la visibilité des couches 

 
Le routage doit se faire en respectant un ensemble de contraintes appelées design rules. Altium 
Designer propose de router sous contraintes, c'est-à-dire qu’il vérifie durant le routage si les règles de 
design sont respectées. Pour les configurer, cliquez sur Design>Rules. La fenêtre suivante apparaît. 
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Figure 20 – Configuration des règles de design 

 
Sur la gauche, toutes les règles de design apparaissent, elles sont configurées par défaut. Les règles 
de design les plus importantes concernent les largeurs des pistes, des vias et les espacements entre 
pistes, vias et plans. Pour créer une nouvelle règle, faites un clique droit dans la liste des règles, au 
dessus de la catégorie où vous voulez la créer, puis sélectionner New Rule. Vous pouvez ensuite 
modifier son nom et la paramétrer. 
Comme le montre la Figure 20, on peut configurer les tailles minimales, préférées et maximales d’une 
piste. Lorsqu’on route une piste, elle prendra par défaut la largeur préférée. Si on modifie sa largeur 
et qu’elle est plus grande que la largeur max ou plus petite que la largeur min, Altium indiquera en 
cours de routage une erreur de design. 
Il est possible d’attribuer une règle de design à un ou plusieurs nœuds ou à une ou plusieurs couches. 
Par défaut, elle est attribuée à tous les nœuds. Pour cela, vous pouvez cocher les cases All, Net, Net 
Class, Layer, Net and Layer.  
On peut aussi importer les règles de routage fournies par le constructeur du PCB sous forme d’un 
fichier .RUL. Pour cela Design>Rules clic droit sur Design rules puis import rules. Ensuite une 
fenêtre s’ouvre, on sélectionne tout puis on clique sur OK . On sélectionne ensuite le fichier .RUL. 
 
 
On peut maintenant commencer à router. Pour cela, on commence par sélectionner la couche sur 
laquelle on veut router. On la sélectionne dans la liste située au bas de l’éditeur PCB. Ensuite, on 
choisit le type d’objet à router (piste, vias, pads, arcs, texte) et le mode de routage (routage simple ou 

différentiel) : . Altium propose un routage interactif, c'est-à-dire qu’il 

anticipe la direction que va prendre la piste simplifiant ainsi le routage. On clique sur l’icône  et on 
clique sur un des pads d’un des circuits pour démarrer le routage d’une piste. Lorsqu’on clique à 
nouveau, on termine un segment de la piste et on en démarre un nouveau. Pour terminer le routage 
de la piste, on appuie sur la touche ECHAP. Lorsque le curseur est au dessus d’un pad qui doit être 
relié à la piste, un cercle apparaît et l’entoure. Le routeur interactif vous propose de connecter ce pad. 
S’il détecte une erreur de design ou une violation de connexion, la piste ou le pad change de couleur. 
 
En cliquant sur une piste, on accède à ses propriétés, notamment le nœud attribué, la largeur 
individuelle de la piste ou la couche sur laquelle elle est routée. 
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Figure 21 – Routage d’une interconnexion 

 
 
Pour supprimer une piste, il suffit de la sélectionner à la souris et d’appuyer sur Suppr. En double 
cliquant sur une piste, on peut accéder à ses propriétés : nœuds, largeur, couche. Pour passer d’une 

couche à une autre, il est nécessaire de placer un via . Si vous placer un via sur une piste, celui se 
connectera automatiquement à la piste en prenant le nom de son nœud. En double cliquant dessus, 
on peut accéder à ses propriétés et modifier sa largeur et le nœud auquel il est connecté. 
 

Pour remplir un espace par un plan cuivré, on clique sur l’icône  ou sur Place>Polygon Pour. La 
fenêtre suivante s’ouvre. Elle permet de définir la texture du plan (plein ou hachuré), la couche 
physique, le nœud auquel il est connecté (le plus souvent, masse ou alimentation) et la manière de 
remplir. Les règles de design définissent les espacements entre le plan et les pistes et les vias, les 
connections aux vias reliés à un même nœud.  
 

 
Figure 22 – Placement d’un plan métallique 

 
Une fois le remplissage configuré, on trace les contours du polygone sur le PCB et on termine la 
saisie en appuyant sur la touche ESC. Une fois terminé, le plan apparaît. Figure 22 à droite présente 
un exemple de plan connecté à la masse. Si l’on déplace les composants connectés au plan, il faut le 
recompiler. On sélectionne le plan à recompiler, clic droit>Polygon Actions>Repour selected ou 
Repour all s’il faut recompiler plusieurs plans. 
 
Pour indiquer au constructeur la taille de notre pcb il est nécessaire d’éditer la Keep Out Layer. On 
positionne alors une ligne faisant tout le tour de la carte. Pour cela cliquer sur Place>keep Out layer. 
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5. Validation du routage (DRC) 
Une fois le routage terminé, il convient de s’assurer que les règles de dessin ont été respectées. 
Normalement, le routeur automatique nous indique les violations de règles de design. Cette validation 
s’appelle Design Rule Check (DRC). On y accède en cliquant sur Tool>Design Rule Check.  
 

 
Figure 23 – Configuration du DRC 

 
A partir de la fenêtre qui s’ouvre (Figure 23), on peut configurer le rapport d’erreurs qui sera généré et 
les erreurs qui seront reportées. Une fois que cela est configuré, on clique sur le bouton Run Design 
Rule Check. Une fois l’opération de DRC effectuée, le rapport de DRC s’ouvre dans une page HTML 
(Figure 24). L’ensemble des warnings et des erreurs sont listés. En cliquant sur une erreur, il est 
possible de la localiser sur la carte. 
 

 
Figure 24 – Exemple de rapport de DRC 
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6. Création d’un panneau  
Lorsque le circuit imprimé est finalisé, si on souhaite en construire plusieurs afin de réduire les couts 
de fabrication, on crée un panneau de cartes. C’est-à-dire que sur un même panneau, on retrouve 
plusieurs exemplaires du même circuit imprimé (ou bien de différents circuits imprimés). Pour cela 
file>new>PCB. Puis on ajoute les cartes préalablement routées avec la commande 
Place>Embedded board array/Panelize. La fenêtre suivante s’ouvre. 

 

 
Figure 25 – Panelize 

 
Dans PCB Document, on sélectionne le fichier .PCBDoc que l’on veut panéliser. Dans Column 
Count et Row Count on indique le nombre d’exemplaires que l’on veut en ligne et colonne. On 
choisit ensuite la taille de la marge entre chaque carte avec Colomn Margin et Row Margin. En 
appuyant sur entrée, on quitte cette fenêtre. On positionne ensuite les cartes sur le PCB. Si sa taille 
ne convient pas View>Board Planing Mode, Design>Edit Board Shape. On place ensuite la 
keepout layer Place>Keepout. Enfin, on peut ajouter de la sérigraphie autour de chaque carte pour 
avoir un guide lors de la découpe du panneau. 
 

 

VI. Création des fichiers de sortie 
Altium Designer propose différents fichiers de sortie standards tels que les fichiers Gerber ou ODB++, 
largement utilisés dans l’industrie pour la fabrication des circuits imprimés. Ses fichiers contiennent 
les informations géométriques de chacune des couches formant le circuit imprimé.  
 

1. Génération des images des masques 
Cela ne constitue pas à proprement parler d’un fichier de sortie. Néanmoins, cela peut être utile pour 
imprimer à échelle réelle les masques du circuit imprimé pour vérifier l’adéquation avec les 
dimensions des composants ou du boîtier dans lequel la carte sera montée. 
Pour cela, on exporte chaque couche au format PDF, à l’aide de l’imprimante PDF. Ces documents 
pourront être directement envoyé à l’impression et générer ainsi les masques. Si on réalise une carte 
deux couches, on réalisera deux images : une pour la face avant, l’autre pour la face arrière. 
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Dans un premier temps, il convient de fixer les paramètres de la page, et notamment de fixer ses 
dimensions. Cette étape est nécessaire pour avoir un dessin à l’échelle. Pour cela, cliquez sur 
File>Page Setup… Choisissez l’orientation de la page, choisissez un mode de couleur noir et blanc 
(option Mono). Pour avoir un dessin à l’échelle, sélectionnez Scaled Print dans l’option Scale Mode 
et fixez Scale à 1. 

 
Figure 26 – Configuration de l’impression du routage 

 
Enfin, cliquez sur le bouton Advanced. La fenêtre ci-dessous apparaît, listant les couches et les 
informations qui seront visibles lors de l’impression. Pour supprimer des couches ou en ajouter, 
appuyez sur le bouton droit de la souris et cliquez sur Delete ou Insert Layer. Cochez la case Holes 
pour faire apparaître les trous de perçage à l’impression. Cette option n’est utile que pour des 
montages traversant.  

 
Figure 27 – Couches visibles lors de l’impression 

 
Dans le cas d’une carte 2 couches, il convient de : 

 réaliser une première image incluant le Top Layer, le Top Overlay (si on souhaite garder 
l’emplacement des composants sur la face avant) et le Keep-Out Layer (pour afficher le bord 
de la carte) 

 réaliser une seconde image incluant le Bottom Layer, le Bottom Overlay (si on souhaite garder 
l’emplacement des composants sur la face arrière) et le Keep-Out Layer (pour afficher le bord 
de la carte) 



Prise en main Altium Designer v19                                                                              Septembre 2019 

A. Boyer 25

 
Pour vérifier ce qui va être imprimé, cliquez sur File>Print Preview. On obtient l’image suivante. Pour 
la sauvegarder au format PDF, cliquez sur Print et utilisez l’imprimante PDF. On obtient ainsi le 
masque pour le top layer. 
 

2. Génération des fichiers Gerber 
Parmi les différents fichiers de fabrication standard de circuits imprimés, le fichier Gerber est le plus 
courant. Il s’agit en fait de plusieurs fichiers (pour faire simple, un fichier par couche à graver) 
contenus dans un fichier zippé. 
Pour générer le fichier Gerber à partir d’un fichier de routage finalisé, ouvrez le fichier et cliquez sur 
File>Fabrication Outputs>Gerber Files. La fenêtre suivante s’ouvre. 
 

 
Figure 28 – Configuration de l’export d’un fichier Gerber 

 
Dans Général, on choisit le système d’unité et la résolution (4 :2 à 4 :4, selon la classe de gravure). 
Pour nos projets, on pourra utiliser le format 4:2. L’onglet Layers permet de sélectionner les couches 
que nous souhaitons envoyer au constructeur. Ensuite on clique sur OK. Il faut généralement y 
ajouter un document indiquant la taille et la position des trous de la carte File>Fabrication 
Outputs>NC Drill Setup. On sélectionne les mêmes options d’unité et de format que pour les 
couches, puis on valide. Les fichiers ainsi générés se trouvent dans 
Altium>Projects>Nom_Projet>Project_Outputs. Ces fichiers pourront être stockés dans un même 
dossier puis zippés et envoyés au fabricant. 
 
 

3. Génération de la liste de matériel (BOM) 
 
La BOM est un document généré par Altium Designer dans lequel on retrouve la liste des 
composants et connecteurs utilisés pour notre projet. Celle-ci peut être transmise en même temps 
que les fichiers GERBER au fabricant afin qu’il commande et soude l’électronique sur notre circuit 
imprimé. On y accède en cliquant sur Reports>Bill Of Material. Cette fenêtre s’ouvre alors, on y 
retrouve la liste de composants, leur description et leur quantité. Dans Export Options, on choisit MS 
Excel File dans File Format puis on exporte, on retrouve alors un tableau excel avec tous les 
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composants. 

 
 

Figure 29 – Interface d’exportation de la BOM 
 

 

VII. Créer une nouvelle librairie intégrée 
La réalisation d’un circuit imprimé commence par une saisie de schématique, qui consiste à 
interconnecter des composants ou des symboles. A ces composants, on peut associer des modèles 
(SPICE) et des empreintes PCB. Les éléments de schématique et d’empreintes PCB sont rangés 
dans des librairies : 
 

 Librairie de schématique .schlib 
 Librairie d’empreintes PCB .pcblib 

 
Cependant, il est aussi possible de placer tous ces composants dans une seule librairie afin 
d’améliorer la portabilité du design et d’avoir tous les composants dans un seul et même fichier. Les 
librairies intégrées sont appelées librairie intégrée et leur extension est .intlib.  
Avant de créer une librairie intégrée, il faut créer la librairie de schématique et d’empreintes, 
opérations que nous allons brièvement décrire dans les prochaines parties. 
 

1. Créer une librairie de schématique 
Avant de créer des composants de schématique, il nous faut créer une librairie de schématique. 
Celle-ci peut être créé telle quelle, comme une simple collection de composants. Cependant, si on 
désire la compiler et y intégrer des modèles pour réaliser une librairie intégrée, il nous faut créer un 
nouveau package de librairie .LibPkg. A l’intérieur, on trouvera de manière séparée les librairies de 
schématique, d’empreintes et les modèles de simulation, qui seront finalement compilés au sein d’une 
même librairie intégrée. 
Pour créer le nouveau package de librairie, on clique sur File>New>Library>Integrated Library. On 
peut le sauver ensuite et modifier son nom en gardant l’extension .LibPkg. Pour ajouter une nouvelle 
librairie de schématique vide, on clique sur File>New>Library>Schematic Library. On crée ainsi un 
package appelé my_lib.LibPkg et une librairie de schématique appelée 
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Schematic_components.SchLib. On obtient l’écran suivant. A gauche, on peut visualiser 
l’arborescence du package. On voit que la librairie de schématique est bien incluse dans le package. 
 

 
Figure 30 – Création d’une nouvelle librairie de composants 

 
On décide de créer un nouveau composant : un amplificateur opérationnel, dont voici le boîtier et le 
brochage. 

 
On crée un nouveau composant en cliquant sur Tools>New Components, on le nomme. La librairie 
contient par défaut un premier composant vide visible à gauche dans l’arborescence Sch Library. 
Avec Tool>Document Options, on peut modifier les paramètres de grille de l’interface graphique 
ainsi que les unités. On commence par construire le corps du symbole, on ne place pas encore les 
lignes des ports d’E/S. Pour cela, on clique sur Place>line. On obtient le résultat suivant.  
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Figure 31 – Création du symbole d’un nouveau composant 

 
On ajoute ensuite les broche ou pins. Pour cela, on clique sur Place>Pin. On place les pins en 
dehors du corps. L’extrémité d’un pin est indiquée par une croix, celle-ci doit être en dehors du corps. 
Avant de relâcher le pin, on peut appuyer sur Tab pour éditer les propriétés du pin : on indique le nom 
qui s’affichera, le désignateur (un numéro), le type électrique et la longueur du segment qui s’affichera. 

 

 
Figure 32 – Propriétés des broches du nouveau symbole électrique 

 
 
On place les 8 pins du composant et on obtient le résultat suivant.  

 
Figure 33 – Création du symbole électrique d’un nouveau composant 
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Dans la liste des composants de la librairie de schématique, on accède aux propriétés du composant. 
On entre les désignateurs par défaut, la description. En cliquant sur Pins, on peut avoir accès à la 
liste des pins et leurs propriétés. 

 
Figure 34 – Edition des propriétés du nouveau composant 

 
En cliquant sur Reports>Component, on obtient un descriptif des pins : 
 
Component Name : AD8000 
 
Part Count : 2 
 
Part : AOP_add/sous 
     Pins - (Normal) : 0 
          Hidden Pins : 
 
Part : AOP_add/sous 
     Pins - (Normal) : 9 
          0              0              Passive 
          Feedback       FB             Passive 
          Negative input -IN            Input 
          Positive input +IN            Input 
          Negative supplyV-             Power 
          Positive supplyV+             Power 
          Power down     SD             Passive 
          output         Vs             Output 
          No connect     NC             Passive 
          Hidden Pins : 

 
On peut vérifier que le composant créé ne comporte pas d’erreurs en cliquant sur 
Reports>Component Rule Check. 
La prochaine étape consiste à ajouter des modèles (SPICE ou empreintes PCB) aux composants de 
la schématique. On peut utiliser des modèles et des empreintes qui existent déjà mais on peut aussi 
en créer de nouveaux. 
 

2. Créer une nouvelle empreinte PCB 
Tout d’abord, il nous faut créer une nouvelle librairie PCB MyPCBLib.PcbLib : 
File>New>Library>PCB Library. L’écran ci-dessous apparaît, avec un nouveau composant PCB par 
défaut appelé PCBCOMPONENT_1. La librairie PCB apparaît dans le package de librairie avec la 
librairie de schématique que nous avons créé tout à l’heure. Sur l’éditeur graphique d’empreinte, le 
cercle blanc indique l’origine. 
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Figure 35 – Création d’un nouveau composant PCB 

 
Plusieurs outils aident à la construction d’une empreinte, comme le PCB Component Wizard auquel 
on accède en cliquant sur Tools>Footprint Wizard. Nous allons plutôt créer une empreinte 
manuellement. On place le curseur sur la zone de travail, en haut à gauche une fenêtre nous indique 
sa position, pour convertir les unités en mm View>Toggle units. On peut aussi modifier la grille 
View>Grids>Global snap grid. 

Ensuite, on place les pads. Pour cela, on clique sur Place>Pad ou sur l’icône . Avant de les placer, 
en cliquant sur tab, on peut modifier les propriétés des pads. On place des pads rectangulaires, de 
longueur 0,8mm et de largeur 0,5 mm. Un numéro est attribué à chaque pad. Lorsqu’on associera 
une empreinte à la vue schématique d’un composant, le lien entre la broche et le pad se fera entre le 
désignateur de la broche et le numéro du pad. Il est indispensable que le même désignateur soit 
employé. 
 
Sur la carte, un vernis recouvrant les pistes sera appliqué par le fabricant mais qui ne doit pas être 
appliqué sur les empreintes. Il faut alors paramétrer le masque de soudure (solder mask). Pour cela, 
double-cliquez sur un pad puis dans solder mask expension, on choisit l’espace entre l’empreinte et 
le vernis. 
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Figure 36 – Edition des propriétés d’une pastille 

 
Après avoir placé les différents pads et modifié leurs propriétés, on peut dessiner le contour du 
composant et ajouter des indications (si nécessaire) en utilisant la couche Top Overlay. On le 

construit en utilisant Place>Line ou l’icône . On obtient le résultat final suivant.  

 
Figure 37 –Dessin d’un nouveau composant PCB 
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Il serait encore possible de construire le modèle 3D du composant, mais on va en rester là et revenir 
à la création de la librairie intégrée. 

3. Ajouter une empreinte à un symbole de schématique 
On peut fermer la fenêtre d’éditeur d’empreinte PCB et revenir à la librairie de schématique. Nous 
avions créé une librairie de schématique Schematic_Components.SchLib et un composant appelé 
AD8000. Ce composant ne dispose que d’un symbole qui pourra être inclus dans une schématique, 
mais si on veut l’utiliser pour du design PCB, il faut lui donner une empreinte PCB. Pour cela, on 
double clic sur AD8000, la fenêtre properties s’ouvre. Dans footprint on clique sur le bouton Add. La 
fenêtre suivante s’ouvre. 

 
Figure 38 – Attribution d’une empreinte PCB à un composant 

 
En cliquant sur Browse, on va chercher la librairie MyPCBLib.PcbLib qu’on a créé, et on sélectionne 
le composant PCBAD8000 On clique sur OK et l’empreinte PCB est ajoutée comme modèle au 
composant Component_1.  
 

 
Figure 39 – Nouveau symbole dans une librairie incluant un symbole électrique et une empreinte PCB 
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4. Création de la librairie intégrée 
On peut créer d’autres symboles de schématique et leur associer des modèles. Ces composants 
peuvent être inclus dans une même librairie intégrée. Dans notre exemple, nous avons un seul 
composant décrit par son symbole de schématique et une empreinte PCB. Ces éléments sont inclus 
dans les librairies Schematic_Components.SchLib et MyPCBLib.PcbLib, elles-mêmes incluses dans 
un package de librairie appelée My_Lib.LibPkg. Une librairie intégrée sera donc créée à partir de ce 
package.  
Pour cela, on compile le package en cliquant sur Project>Compile Integrated Library. Si la 
compilation se déroule sans erreur, on peut retrouver dans components notre schématique associé a 
son empreinte. Elle est désormais utilisable dans une schématique. 
 

 
Figure 40 – Création d’une nouvelle librairie intégrée 

 
 
 

VIII. Modélisation des composants de la carte en 3D 
 

Sous Altium Designer, il est possible de visualiser sa carte en 3D. Pour cela on utilise la touche 
3 du clavier ou View>3D Layout Mode. On a ainsi un aperçu du rendu de la carte après fabrication. 

 
Figure 41 – Vue 3D du PCB 
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On remarque que les composants ne sont pas présents sur cette vue. Comme pour la vue 2D, il n’y a 
que leurs empreintes. Il peut être intéressant de les ajouter pour avoir une idée de l’encombrement de 
la carte et anticiper d’éventuels problèmes d’intégration de la carte. La création d’un modèle 3D peut 
se faire à deux étapes de la conception : 

 soit à la création de l'empreinte du composant 
 soit pendant la phase de routage 

 
Pour ajouter une vue 3D simplifiée aux composants, il faut se rendre dans la librairie d’empreinte 
puis Place>3D Body. En appuyant sur la touche TAB on accède aux paramètres permettant de 
générer des modèles 3D avec des formes génériques. 
 

.  
Figure 42 – Paramètres de l’outil de création de modèles 3D génériques de composant 

 
Une couche est indispensable pour faire passer les informations sur le modèle 3D du composant. 
Pour cela, on utilise une couche mécanique. Dans cet exemple, on place le modèle 3D sur la couche 
mécanique 1. Dans 3D Model Type, on sélectionne la forme du modèle : Extruded, pour une forme 
quelconque, cylinder ou sphere. En fonction de celle-ci on peut choisir ses caractéristiques. On 
retourne ensuite en mode édition, on dessine le composant à l’aide de l’outil en 2D puis on clique sur 
ECHAP. Sur le routage 2D, un rectangle dessiné  l’aide de la couche Mechanical 1 fait apparaitre 
l’encombrement du composant (Figure 43 à gauche). En cliquant sur 3, on peut voir notre composant 
en  3D (Figure 43 à droite). Si on clique dessus on peut modifier ses paramètres : taille, diamètre, 
hauteur … 
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Figure 43 – Vue du modèle géométrique du composant en 2D (à gauche) et en 3D (à droite) 

 
On peut aussi importer des composants d’internet : Place>3D Body puis on clique sur la touche TAB 
en cliquant sur Generic puis dans Source sur Choose, on peut importer des modèles sous la forme 
de ficher .stp ou STEP. Le placement se fait de la même manière que précédemment.  

 

 
Figure 44 – Vue 3D du PCB avec les composants 

 
Pour plus d’informations sur la génération des modèles 3D, vous pouvez consulter les deux 
ressources suivantes : 
 

 https://www.youtube.com/watch?v=6AU94oTnG68  
 https://resources.altium.com/whitepapers/creating-component-bodies-in-a-footprint-library  

 


