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ObjectifsObjectifs

> Prise en main de l’environnement ANSYS Electronics Desktop (V16) – HFSS

> Création d’un projet from scratch

> Flot de modélisation et post-processing typique

> Utilisation des opérations logiques pour construire une géométrie

> Validation des résultats de simulation sur un cas simple

> Export des résultats (fichier Touchstone et circuit équivalent SPICE) 

> Lien avec les autres outils de ANSYS Electronics Desktop (Nexxim Circuit 
Simulator) : modèle statique (N port) et lien dynamique
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Cas 1Cas 1

> Une boucle circulaire de rayon Rloop = 5 mm, constitué d’un fil de rayon Rwire = 0.5 
mm

> Le fil est en cuivre.

> Il est excité par un générateur de tension interne de 20 V et d’impédance de sortie 50 Ω
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Premières options à réglerPremières options à régler

> Tools > Options > General Options : 
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Premières options à réglerPremières options à régler

> Tools > Options > 3D Modeler Options :

> Dans le volet Drawing, cochez « Edit Properties
of New Primitives » 
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Création du projet / design HFSSCréation du projet / design HFSS

> File > New  création d’un nouveau 
projet

> Renommer en MagneticLoop1

> Insertion d’un design HFSS, qu’on 
nommera MagneticLoop.

> File > Save as  sauvegarde du projet

> Réglage du type de solution (Tools > 
Options > General Options )

> Réglage des unités (en mm) : Modeler > 
Units
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Création des variablesCréation des variables

> Créer les variables suivantes

> HFSS > Design properties > bouton Add ou clic droit sur le nom du projet > Design properties
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Définition du modèle géométriqueDéfinition du modèle géométrique

> La géométrie peut être créer à l’aide d’un tore.

> Clic sur Draw torus(dispo aussi dans Draw > Draw box)

> Dimensions et définition du matériau :
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Définition du modèle géométriqueDéfinition du modèle géométrique
> Il est nécessaire de créer une ouverture dans la boucle 

pour placer un port d’alimentation.

> Commençons par changer le système de coordonnées : 
View > Grid System

> Passage en coordonnées polaires



LAAS-CNRS
/ Laboratoire d’analyse et d’architecture des systèmes du CNRS 10

Définition du modèle géométriqueDéfinition du modèle géométrique
> Dessiner une ligne délimitant une petite portion de la boucle (Draw Line)

> Un objet polyline est créé définissant une surface fermée d’épaisseur nulle.
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Définition du modèle géométriqueDéfinition du modèle géométrique
> Sélectionner l’objet polyline et lui attribuer une épaisseur supérieure 

à 2 * Rwire : Modeler > Surface > Thicken Sheet.
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Définition du modèle géométriqueDéfinition du modèle géométrique
> On sélectionne l’objet boucle et l’objet polyline.

> Modeler > Boolean > Substract  on supprime la portion 
de boucle délimitée par polyline.

Ouverture
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Définition du modèle géométriqueDéfinition du modèle géométrique
> Pour placer le lumped port, on doit créer une surface placée à 

l’intérieur de l’ouverture.

> Créer un cercle de rayon Rloop+Rwire (Draw Circle), puis créer 
un second cercle de rayon Rloop-Rwire. Les 2 cercles sont 
centrées en (0,0,0). 

> Il est possible de copier/coller le premier cercle puis de modifier 
ses propriétés.

> Modeler > Boolean > Substract  on conserve un anneau, 
délimité par les 2 cercles.
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Définition du modèle géométriqueDéfinition du modèle géométrique
> A l’intérieur de l’objet Loop, on récupère l’objet polyline et on le 

copie/colle.

> On réalise l’intersection entre l’anneau précédent et l’objet 
polyline : Modeler > Boolean > Intersect

Ouverture

Surface pour 
placer le port
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Création des excitationsCréation des excitations
> Sélectionnez la surface à l’intérieur de l’ouverture (Edit > Select 

> Faces), clic droit : Assign Excitation > Lumped port

> Attribuez numéro 1

> Ajout d’un terminal : HFSS > Assign Excitation > Terminal
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Création des excitationsCréation des excitations
> Réglage de la tension du générateur de tension : HFSS > Field > Edit Sources

> Vgene correspond à la tension aux bornes du générateur lorsqu’il est chargé par 50 Ω, donc la 
tension interne est égale à 2xVgene.
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Création des conditions aux limitesCréation des conditions aux limites
> Tout l’espace autour du modèle est considéré par défaut comme du Perfect Electric 

Conductor (PEC)  il faut le changer si on veut créer un volume ouvert.

> Définition de l’Air Box. 

> Dimensions recommandées : compromis entre précision et temps de calcul. Une distance 
d’au moins λ/4 entre le modèle et le bord rayonnant.

> Dessin d’une boite autour du design (Drawing Plane  XY et Draw Box)
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Création des conditions aux limitesCréation des conditions aux limites
> Création de limites de type « Radiation boundary » au-dessus du substrat  espace ouvert.

> Sélection des faces par : Edit > Select > By name
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Création des conditions aux limitesCréation des conditions aux limites
> Clic droit > Assign Boundary > Radiation
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Réglage des solutionsRéglage des solutions
> Pour une analyse rapide (temps de simulation court, de l’ordre de 3 min) :

> HFSS > Analysis setup > Add solution setup : on définit la fréquence à laquelle la 
structure sera maillée et le processus de calcul adaptatif sera effectué (nom  Setup1)
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Réglage des solutionsRéglage des solutions
> Pour une analyse plus fine (temps de simulation long, de l’ordre de 30 min.) :

> HFSS > Analysis setup > Add solution setup : on définit la fréquence à laquelle la 
structure sera maillée et le processus de calcul adaptatif sera effectué (nom  Setup1)
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Réglage des solutionsRéglage des solutions
> HFSS > Analysis setup > Add Frequency sweep: on définit la plage de fréquence sur 

laquelle on calcule les solutions (le maillage n’est pas raffiné à ces fréquences)

> On sélectionne Setup1.

Pour conserver les champs 
(E, H, J…) à l’intérieur du 

volume de calcul !!!
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VérificationVérification
> HFSS > Validation check          : vérification du modèle (géométrie, excitation, conditions 

aux limites) et de l’analyse.

Warning : pour avertir que le calcul 
à l’intérieur des conducteur requiert 
un maillage fin !
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Lancement de la simulationLancement de la simulation
> HFSS > Analyze All

> Temps de calcul dépendant du nombre de mailles, du nombre de fréquence, du nombre de 
passes pour converger …. 

> Toujours commencer par un nombre réduit de fréquences et de passes pour évaluer le 
temps de calcul requis pour le modèle et la simulation finale

> Avancement visible dans la fenêtre Progress.

> Si la simulation se termine correctement :
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Analyse des résultatsAnalyse des résultats
> HFSS > Results > Solution data

> Visualisation du temps de simulation, de la convergence, du maillage …
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Calcul de l’inductance de la boucleCalcul de l’inductance de la boucle
> Théoriquement, l’inductance d’une boucle circulaire, de rayon Rl, formé d’un fil de rayon Rw

est donnée par :

଴ ௟
௟

௪
Dans note cas : Ltheorique = 15 nH 

> HFSS > Results > Create Terminal Solution Data Report > Rectangular Plot  Z parameters

Lsimu = 14.8 nH 
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Calcul de la résistance de la boucleCalcul de la résistance de la boucle
> Théoriquement, en basse fréquence (sans effet de peau) :

஽஼
௟

௪
Dans note cas : RDC = 0.7 mΩ

f
 1
 A 100 MHz : δ = 6.6 µm 

஺஼
௟

௪
ଶ

௪
ଶ

A 100 MHz : RAC = 26 mΩ

> En prenant en compte l’effet de peau :
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Tracé du courant surfacique : HFSS > Fields > Plot Field > J > Mag_Jsurf

> L’effet de proximité sur la distribution de la densité de courant est clairement visible.
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Théoriquement : ௚௘௡௘

௚௘௡௘ ௕௢௨௖௟௘

A 100 MHz : |I| = 393 mA
A 1000 MHz : |I| = 188 mA

> Deux méthodes pour mesurer le courant sur le modèle :
 On mesure la densité de courant traversant la section du 

conducteur

 On mesure le champ magnétique le long d’un contour C 
fermé placé autour du conducteur

௩௢௟
ௌ௘

஼
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Méthode 1 : intégration du courant à travers la section du conducteur

> On créé une surface à l’intérieur du conducteur (Draw Circle) 

Ouverture
Mesure du courant 
traversant cette surface 
(ProbeCurrent)
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Calculatrice de champ : HFSS > Fields > Calculator

> Opération (attention, il faut faire l’intégration sur la partie réelle puis sur la partie imaginaire) :
 Quantity > Jvol

 Complex > Real

 Geometry > Surface > ProbeCurrent

 Normal

 ∫

 Complex > CmplxReal

 Quantity > Jvol

 Complex > Imag

 Geometry > Surface > Probe Current

 Normal

 ∫

 Complex > CmplxImag

 +

 Add  enregistré sous LoopCurrent
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Méthode 2 : intégration du champ magnétique sur un contour fermé autour du conducteur

> Au préalable, décocher l’option « Automatically cover closed polylines » dans Tools > 
Options > 3D Modeler Options

> Dessiner un cercle autour du conducteur quelque part sur la boucle. Celui-ci doit entourer 
complètement le conducteur, mais ne doit pas être trop large.

Ouverture

Contour fermé 
(ProbeCurrent2)
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Calculatrice de champ : HFSS > Fields > Calculator

> Opération (attention, il faut faire l’intégration sur la partie réelle puis sur la partie imaginaire) :
 Quantity > H

 Complex > Real

 Geometry > Line > ProbeCurrent2

 Tangent

 ∫

 Complex > CmplxReal

 Quantity > H

 Complex > Imag

 Geometry > Line > ProbeCurrent2

 Tangent

 ∫

 Complex > CmplxImag

 +

 Add  enregistré sous LoopCurrent2
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Calcul du courant dans la boucleCalcul du courant dans la boucle
> Comparaison des 2 méthodes :

Intégration du courant

Intégration du champ H

> Remarque : avec le maillage par défaut, à 100 MHz, le courant estimé par la première méthode 
est de 520 mA, et de 391 mA avec la seconde méthode. La première méthode est sensible à la 
qualité du maillage à l’intérieur du conducteur !
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Calcul du champ magnétiqueCalcul du champ magnétique
> Théoriquement, dans l’axe Z de la boucle, en supposant que le courant est uniforme le long 

de la boucle, le champ magnétique est donné par : 

௟
ଶ

ଶ
௟
ଶ ଷ

ଶൗ

A z= 1.5 mm: |H| = 34.5 A/m
A z= 5 mm: |H| = 12.7 A/m
A z = 10 mm : |H| = 3.05 A/m

> On trace une ligne normale à la boucle partant du centre (ProbeHFieldZaxis)

> HFSS > Results > Create Field Report > Rectangular Plot
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Couplage entre deux bouclesCouplage entre deux boucles
> Sauvegarder le projet sous MagneticLoop2. Supprimez 

tous les graphes de résultat.

> Créer une nouvelle variable : Sep = 5 mm.

> Changer le nom de la boucle  LoopEmetteur

> Copier la boucle existante, la coller et la renommer 
LoopRecepteur.

> Translation de Z = -Sep/2 de la boucle LoopEmetteur
(Edit > Arrange Move)

> Translation de Z = Sep/2 de la boucle LoopEmetteur
(Edit > Arrange Move)

> Même chose pour le port de la boucle LoopEmetteur, 
que l’on renommer PortEmetteur.

> Copier ce port et le renommer PortRecepteur.

On va calculer le couplage entre ces deux bobines.
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Réglage des solutionsRéglage des solutions
> On peut réduire la taille du volume airbox (on réduira 

ainsi le temps de calcul 

> Setup1  on revient sur le setup par défaut (ordre des 
fonctions de base = 1 avec lambda target = 0.333)

> Sweep par interpolation entre 0 et 2 GHz, avec 
balayage log.

> On décoche les options solve inside dans les 2 
boucles.

> On lance la simulation.



LAAS-CNRS
/ Laboratoire d’analyse et d’architecture des systèmes du CNRS 38

Résultat paramètres SRésultat paramètres S
> HFSS > Results > Create Terminal Solution Data Report > Rectangular plot
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Export fichier TouchstoneExport fichier Touchstone
> Clic droit sur Sweep dans le Project Manager > 

Network Data Explorer

Export Touchstone (.snp)

Export SPICE subcircuit
(HSPICE, Spectre, PSPICE)

Test causalité
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Export fichier TouchstoneExport fichier Touchstone
> Analyse paramètres S 

> Quantity > Matrix Statistics > Passivity (doit être < 1)
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Export fichier TouchstoneExport fichier Touchstone
> Analyse paramètres S 

> Check > Causality
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Export fichier TouchstoneExport fichier Touchstone
> Bouton SYZ Data
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Export sous-circuit SPICEExport sous-circuit SPICE
> Bouton Broadband
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Bouton Insert Circuit Design

> On l’enregistre sous CircuitCoupledLoops.

> View > Component Libraries pour afficher le volet des librairies de composants (à droite de 
l’écran)

> Sélectionner la catégories et « drag and drop » le composant à placer.
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Set-up pour extraire l’inductance mutuelle (une alternative est de simuler directement le 

paramètre Z12)

> On ajoute un composant N ports, qui va contenir le fichier .s2p décrivant le couplage entre les 
2 boucles, précédemment généré.

Source AC (1 V)

Sonde de courant Sonde de tension

Terminal 
LoopRecepteur

Terminal 
LoopEmetteur

Modèle Nport des 2 
boucles couplées

ଵଶ
௥௅௢௢௣

ா௠௜௧௅௢௢௣
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Configuration d’une simulation AC : Circuit > 

Add Nexxim Solution Setup > Linear Network 
Analysis

> Lancement de la simulation : Circuit > 
Analyse (F10)
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Affichage des résultats de simulation : interface commune aux outils ANSYS Electronics Desktop

> Circuit > Results > Create Standard Report > Rectangular Plot

Expression à écrire
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Calcul de |Z12| : 

Mutuelle inductance M = 2.36 nH
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Inconvénient de l’approche Nports : si on modifie le modèle 3D sous HFSS, il est nécessaire de 

reconstruire le fichier Touchstone et de le changer sur Nexxim circuit simulator.

> Une autre approche consiste à créer un lien dynamique entre le modèle circuit et le modèle 
électromagnétique (HFSS), permettant ainsi une vraie cosimulation.

> Les signaux issus de la simulation circuit vont excités le modèle électromagnétique, dont les 
résultats vont alimenter le modèle circuit.

> Seules les simulations Linear network et transitoires fonctionnent selon ce principe ! 

> Pour cela, on créé un Dynamic Link entre Nexxim Circuit Simulator et HFSS. 

> Tout se fait depuis Nexxim Circuit Simulator
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Clic droit sur Circuit dans Project Manager

> Add Subcircuit > Add HFSS Link

> Sélectionner le modèle HFSS et OK
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Une boite avec les ports du modèle HFSS et une image miniature du modèle géométrique 

apparait.

> Le modèle HFSS s’ouvre aussi, s’il n’est pas ouvert.

> Clic droit > Edit Component 
définition du composant

> Clic droit > Edit Symbol  pour modifier 
le symbole apparaissant sur la 
schématique

> Clic droit > Edit Link Definition  pour 
modifier le lien avec HFSS
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Set-up de simulation des paramètres S/Z
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Simulation sous Nexxim circuit simulatorSimulation sous Nexxim circuit simulator
> Résultat de simulation (Z11 et Z12)

Mutuelle inductance M = 2.41 nH


